Форум консультаций по прикладным решениям и программам фирмы "1С".
Онлайн консультации, вопросы и ответы, бесплатная регистрация, личная страница, twitter и facebook каналы и многое другое ждут Вас здесь.
Зарегистрироваться ← Ваш выбор →

Условие выбора сотрудника

Тема в разделе '1C:8 "Общие вопросы по прикладным решениям"', создана пользователем konstantin163, 01.03.2015.

  1. Не в сети

    konstantin163 Новичок

    Есть справочник *Сотрудники*. В нем 2 группы: *Кладовщики* и *Продавцы*. В них соответственно фамилии сотрудников.
    Есть документ *Продажа*. В нем реквизит *Сотрудник*, который является ссылкой на справочник *Сотрудники*.
    Хочу чтобы при выборе сотрудников из папки *Кладовщики выдавалась ошибка.
    Написал следующий код:
    &НаКлиенте
    Процедура СотрудникПриИзменении(Элемент)

    Результат = Проверить(Объект.Сотрудник);
    Если Не Результат Тогда
    Сообщить("не может быть выбран");
    КонецЕсли;
    КонецПроцедуры

    &НаСервереБезКонтекста
    Функция Проверить(Сотрудник)
    //а = 0;
    если Сотрудник.Родитель = Справочники.НайтиПоКоду("000000002") тогда Результат = истина;
    иначе Результат = ложь;
    возврат Результат
    КонецЕсли;
    КонецФункции

    но в самом предприятии при выборе сотрудника вылазиет ошибка: метод объекта не обнаружен(найтипокоду)*. Что не так?
    Помогите!!!!
  2. Реклама на форуме

    Чтобы убрать:

  3. Не в сети

    Владимир Владимирович Известная личность

    Справочники.Сотрудники.НайтиПоКоду....

Похожие темы

Тема по ключевым словам: условие, выбора.
Статистика
Последнее сообщение
  1. Интех
    Ответов:
    0
    Просмотров:
    62
    Интех
    27.07.2018
  2. Алексей1975
    Ответов:
    9
    Просмотров:
    4.821
  3. Интех
    Ответов:
    0
    Просмотров:
    217
    Интех
    06.09.2016
  4. Michail
    Ответов:
    3
    Просмотров:
    824
  5. Annete
    Ответов:
    3
    Просмотров:
    1.323
    Andrey
    04.03.2014
Загрузка...