Форум консультаций по прикладным решениям и программам фирмы "1С".
Онлайн консультации, вопросы и ответы, бесплатная регистрация, личная страница, twitter и facebook каналы и многое другое ждут Вас здесь.
Зарегистрироваться ← Ваш выбор →

Здравствуйте, помогите по 1С.

Тема в разделе 'Программирование и администрирование в 1С', создана пользователем Ioann, 17.05.2012.

  1. Не в сети

    Ioann Новичок

    Здравствуйте. В конфигурации 1С создал в документах платёжное поручение. Вот выгрузка базы:
    http://clip2net.com/s/1VKsk
    1. Открываю уже созданное
    [IMG]

    2. Изменяю, жму провести закрыть
    [IMG]

    3. Изменяется то, что уже было создано
    [IMG]

    Нужно чтобы 1 раз создал, затем можно было только просмотреть/распечатать, а не изменять и создать новый документ...

    В форме документа "ПлатежноеПоручение" убрал галочку в разделе доступность. Теперь не могу изменять созданные документы, могу печатать, но не могу создать новый.

    Подскажите, пожалуйста, что нужно сделать...
  2. Реклама на форуме

    Чтобы убрать:

  3. Не в сети

    Владимир Владимирович Известная личность

    Обрабатывать событие ПередЗаписью
    Код:
    Если НЕ Параметры.Ключ.Пустая() Тогда
      Отказ=Истина;
    КонецЕсли;
  4. Не в сети

    Ioann Новичок

    А не подскажите куда это записать нужно?
  5. Не в сети

    Владимир Владимирович Известная личность

    события формы, Вам решать где на клиенте или на сервере
  6. Не в сети

    Ioann Новичок

    ура, я нашёл=) нужно было на лупу нажать там=)

    &НаКлиенте
    Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    Если НЕ Параметры.Ключ.Пустая() Тогда
    Отказ=Истина;
    КонецЕсли;
    КонецПроцедуры
    спасибо=)
  7. Не в сети

    Ioann Новичок

    мне потом друг подсказал записать в форму в событие ПриОткрытии:

    &НаКлиенте
    Процедура ПриОткрытии(Отказ)
    ЭтаФорма.Доступность= Объект.Ссылка.Пустая();
    КонецПроцедуры
    тогда получается то, что было, когда убирал галочку в доступности, но теперь можно создавать, а то что уже создано печатать и вообще никак изменять:
    [IMG]

Похожие темы

Тема по ключевым словам: здравствуйте, помогите.
Статистика
Последнее сообщение
  1. Maydik
    Ответов:
    1
    Просмотров:
    1.468
    _Igor_
    07.03.2016
  2. Chebotar
    Ответов:
    0
    Просмотров:
    686
    Chebotar
    10.12.2015
  3. Burger53
    Ответов:
    1
    Просмотров:
    3.524
    Andrey
    17.06.2015
  4. Лесник
    Ответов:
    11
    Просмотров:
    3.039
    Лесник
    31.01.2015
  5. Ira79
    Ответов:
    0
    Просмотров:
    2.642
    Ira79
    10.12.2014
Загрузка...